ICS/Lotus (mostly), Linux, Travel, Skiing, Mixology, and Random Musing of Interest

Fixing "Unable to locate Perl on this system" for Domino on Linux and UNIX

Bill Malchisky  September 17 2013 12:05:00 AM
IBM published a new requirement for Domino on both UNIX and Linux, in that they are now using an updated Perl version. Thus, any package created after July 2012 needs version 5.6.0 or better. This got my attention recently as the technote was included in the D8.5.3 FP5 Release Notes, from August. Know that this requirement only pertains to Domino. If you do not have the proper Perl version installed, you will see an "Unable to locate Perl on this system" error when applying your hotfixes and Fix Packs.

If you are running IBM Domino 9, then you are fine as both the new required RHEL and SLES version satisfy the need. But, if you are running an older version of RHEL or SLES for Domino 8.x or 8.5.x, then you should check.

Two ways to perform this very simple test
1. $perl -v
Output i386, RHEL5: This is perl, v5.8.8 built for i386-linux-thread-multi
Output x64, RHEL6: This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

2. $ rpm -qa |grep perl
Output i386, RHEL5:
perl-Net-SSLeay-1.30-4.fc6
newt-perl-1.08-9.2.2
perl-Crypt-SSLeay-0.51-11.el5
perl-String-CRC32-1.4-2.fc6
perl-5.8.8-18.el5 <-----------Here


Output x64, RHEL6:
perl-Pod-Simple-3.13-131.el6_4.x86_64
perl-Pod-Escapes-1.04-131.el6_4.x86_64
perl-libs-5.10.1-131.el6_4.x86_64
perl-version-0.77-131.el6_4.x86_64
perl-5.10.1-131.el6_4.x86_64  <-----------Here
perl-Module-Pluggable-3.90-131.el6_4.x86_64

You can see in both examples that you can derive the precise Perl version accurately. Note that depending upon your current system patch level, you may see different Perl versions in your environment.
Comments
No Comments Found

Powered by IBM Lotus Domino 8 | Lotus User Group | Get Firefox! | This blog is listed on Planet Lotus   IBM Certified

© 2010 William Malchisky.